Upgrade to Pro
— share decks privately, control downloads, hide ads and more …
Speaker Deck
Sign up for free
Menu
Search
Features
All features
Private URLs
Password Protection
Custom URLS
Scheduled publishing
Remove Branding
Restrict embedding
Deck Collections
Notes
Features
All features
Private URLs
Password Protection
Custom URLS
Scheduled publishing
Remove Branding
Restrict embedding
Deck Collections
Notes
Explore
Featured decks
Featured speakers
Programming
Technology
Storyboards
Explore
Featured decks
Featured speakers
Programming
Technology
Storyboards
Pricing
Search
Sign in
Sign up for free
NAT64/DNS64を試してみた&試してみよう
Search
Rijuo
June 19, 2017
Technology
770
0
Share
Embed
Copy iframe code
Copy JS code
Copy link
Start on current slide
NAT64/DNS64を試してみた&試してみよう
Rijuo
June 19, 2017
Other Decks in Technology
See All in Technology
しろおびから始める!ログ活用の第一歩
shumei_ito
0
950
Webの常識が通じないHTMLメールのダークモード
teamlab
PRO
0
120
How to Design Configuration for Rails Applications
willnet
1
770
日本語に強いオープンな大規模言語モデル「LLM-jp」
odashi
4
1.1k
NDIでApple Vision Proにリアルタイム映像送信
jyouryuusui
0
120
⾮構造化データを価値に変える AI エージェント基盤とその組織
ivry_presentationmaterials
0
190
V8のArray.prototype.flatを最大約20倍速くするまでと、巨大OSSへの大規模コミットの道のり
riyaamemiya
0
290
UniFi(ユニファイ)AIカメラの現場活用
ludicmind
1
440
無理せず続ける、子育てエンジニアの学び
codmoninc
PRO
0
860
JAWS-UGグッズ職人仕事の流儀
kentapapa
0
100
Claude の新機能を、 出た日に触って社内に届けるまで
rfdnxbro
1
170
AI コーディングと人間の認知スループット / CTO Night & Day 2026 Morning Session / AI Coding and Human Cognitive Throughput
prog893
4
1k
Featured
See All Featured
Making the Leap to Tech Lead
cromwellryan
135
10k
Learning to Love Humans: Emotional Interface Design
aarron
275
41k
How Fast Is Fast Enough? [PerfNow 2025]
tammyeverts
3
940
Joys of Absence: A Defence of Solitary Play
codingconduct
1
550
Intergalactic Javascript Robots from Outer Space
tanoku
273
28k
The Power of CSS Pseudo Elements
geoffreycrofte
82
6.6k
[Rails World 2023 - Day 1 Closing Keynote] - The Magic of Rails
eileencodes
38
3.1k
AI Search: Where Are We & What Can We Do About It?
aleyda
0
8.1k
Technical Leadership for Architectural Decision Making
baasie
3
600
Creating an realtime collaboration tool: Agile Flush - .NET Oxford
marcduiker
35
2.6k
Connecting the Dots Between Site Speed, User Experience & Your Business [WebExpo 2025]
tammyeverts
11
1.1k
What’s in a name? Adding method to the madness
productmarketing
PRO
24
4.2k
Transcript
NAT64/DNS64を試してみ た&試してみよう 山崎 利樹 インターネットイニシアティブ
IPv4 枯渇について http://webfun.tech/how-sakurainternet-assign-ipv4-address/
IPアドレスをゲットするには… • 1指定業者あたり/22を1ブロックの分配しか受けられない。 • IP指定業者間でIPv4アドレスの移転をする。 • 1IPアドレス当たり¥***で売買される。 • IPv4アドレス移転の履歴 https://www.nic.ad.jp/ja/ip/transfer/ipv4-log.html
EMERGENCY EMERGENCY EMERGENCY EMERGENCY EMERGENCY EMERGENCY EMERGENCY EMERGENCY EMERGENCY EMERGENCY
EMERGENCY EMERGENCY EMERGENCY EMERGENCY EMERGENCY EMERGENCY
https://www.google.com/intl/ja/ipv6/statistics.html#tab=ipv6-adoption&tab=ipv6-adoption IPv6の普及状況
http://kokatsu.jp/blog/ipv4/ 日本におけるIPv6アクセス網の普及率が30%を突破(6/2)
身近にもうIPv6が
IPv6への移行技術 • トンネリング • 6to4(RFC3056) • ISATAP(RFC4214) • 6rd(RFC5569) •
トランスレーション • NAT64/DNS64 • ISATAP • 464XLAT • デュアルスタック • DS-Lite
環境説明 • DNS64 • Google DNS64 • 2001:4860:4860::6464 • 2001:4860:4860::64
• DHCPv6 • SEIL X1のルータの機能で。 • NAT64 • Jool 3.5.3
NAT64/DNS64の仕組み DNS64 IPv6ネットワーク NAT64 IPv4 IPv6 DNS64は対象にIPv6アドレスがない場合 64:ff9b::/96 にIPv4のアドレスを埋め込む IPアドレス:1.2.3.4
① ② ③
環境説明 IPv6 DNS64 2001:4860:4860::6464 2001:4860:4860::64 IPv4 XXX.XXX.XXX.1/29 XXX.XXX.XXX.0/29 XXX.XXX.XXX.2/29 SSID:CIXS-NAT64-IPV6
XXXX:XXXX:XXXX:XXXX:33a1:a9ba:557a:55df XXXX:XXXX:XXXX:XXXX::1 XXXX:XXXX:XXXX:XXXX:2e0:4dff:fe10:15c1 NAT64 Route: 64:ff9b::/96 →XXXX:XXXXX:XXXX:XXXX:33a1:a9ba:557a:55df
NAT64で、できないこと • Skype • IPSec VPN
総括 • 使えないサービスが一つでもあるとやる気を失う
DS-Liteがいいかもしれない http://techlog.iij.ad.jp/archives/1879