Upgrade to Pro — share decks privately, control downloads, hide ads and more …

IoT enabled Bee Health

Sponsored · SiteGround - Reliable hosting with speed, security, and support you can count on. →

IoT enabled Bee Health

Using IoT technologies for addressing the Colony Coilapse Disorder. We propose an architecture for an end-to-end solution using, 6LoWPAN, LoRA and microservices. Focus on the gateway component architecture.

Avatar for António Almeida

António Almeida

September 15, 2016

More Decks by António Almeida

Other Decks in Technology

Transcript

  1. who are we? edge to edge IoT enabler from the

    sensing edge to the cloud edge deliver effective IoT market solutions
  2. IoT 101: constrained devices low computing power: CPU, memory, etc

    unreliable networking: mesh, 6LoWPAN, BLE low power consumption: small duty cycle RFC 7228
  3. the problem: colony collapse disorder worker bees abandon colony it

    dies soon after exact causes are unknown pesticides, parasites, changes in flora, malnutrition, &c
  4. participants project originally started by Cisco as CSR we embraced

    it immediately CSIRO is a governmental research lab from Australia project is part of Global Bee Health Initiative
  5. our approach I: monitoring beehives & bee behavior solution ranging

    from DIY to full scale industrial deployment price range varies accordingly from 100s to 1000s of USD from consumer to industrial grade hardware all code available as free software
  6. our approach II: what to monitor 1st phase: weight of

    beehive, temperature and humidity 2nd phase: 3D thermal imaging, acoustic fingerprinting, infrared for bee counting
  7. architecture: 30000 ft view 6LoWPAN, i.e., IPv6 running on top

    of IEEE 802.15.4 (PHY + MAC) gateway - can be many things LoRa/LoRaWAN for long range – 5 km in urban environments, 20km in suburban
  8. what is 6LoWPAN? make IPv6 work over 802.15.4 - handle

    fragmentation, compression IETF RFC 4944, RFC 6282, RFC 6775 radio uses ISM band: 868 MHz (EU), 915 MHz (US), 2.4 GHz (world) data rates up to 250 kbps
  9. what is the gateway? leverages concept of fog computing it

    can do a lot of things 6LoWPAN border router input filters, e.g., CoAP to HTTP adapter (proxy) stream analytics local control loops - rules engine
  10. what is LoRa/LoRaWAN? patented Chirp Spread Spectrum (CSS) passband modulation

    technique developed by Semtech LoRaWAN is the network technology (MAC layer) uses a start based topology for the network long range – 5 km in urban environments, 20km in suburban
  11. DIY and/or operator based LoRaWAN network - a LoRaWAN gateway

    acts as a between IP and edge - deploy your own network of LoRaWAN gateways
  12. gateway revisited expanding on fog computing the edge can be

    anything it can be a rack full of powerful servers or it can be a 6LoWPAN border router depends on the application
  13. gateway: posing the problem needs to be highly-available needs to

    be scalable needs to be lightweight needs to be reliable
  14. component services I: input/output filters converts from one data format

    to another converts from one application protocol to another compresses the data omitting superfluous information inserts (additional) metadata into the given input/output can be composed with other services
  15. component services II: local storage function as a backup for

    data sent upstream can be used to buffer the transmission of data uptream can be used as an edge data warehouse can be composed with other services
  16. component services III: rules engine establish localized control loops, i.e.,

    not defined in some sort of upstream rules can be fired using pattern matching can function as backup for control loops defined upstream can be composed with other services to create additional services
  17. component services IV: device management registry of all devices that

    interact with the gateway update device models locally remove, add and update devices on the edge firmware updates, bootstrapping, etc
  18. component services V: streaming analytics compute indicators specific to the

    business it serves smooth out, average out, remove superfluous information build better control loops through better data modeling provide immediate business insights can be composed with other services,
  19. component services VI: authentication & authorization defines unambiguously the allowed

    interactions between devices establishes and enforces realms of action for the devices on the network composable with other services for creating new realms of activity