IP network products Founded October 1994 Internal alpha network operational November 1995 First beta site installed January 1996 Introduction of industry’s first IP Switch March 1996 First customer shipments April 1996 Introduction of FAS1200 September 1996 Over ninety full-time employees as of November 1996
VP Marketing Peter Buhl Director of Finance John Carosella VP Corporate Development Bob Hinden Director of Routing Software Don Jaworski VP Engineering Greg Minshall Tom Lyon Brian NeSmith Founder and CTO President and CEO Member of Technical Staff Larry Lang VP Product Management Khaled Nasr GM Americas Region Dr. Peter Newman Member of Technical Staff Randy Ziffer VP of Operations
7 coverage Diagnostics support Next-business day replacement of defective hardware Factory-performed systems assembly and test Product installation support Product training Software updates and upgrade assistance
service automation Call-Tracking Database Linked to business and ECO systems Designed with Web integration for direct query of problem, product or account information by registered customers Service Automation Automatic e-mail notification of new software releases Development of Network Profiles for problem notification Web-based network management application with links to support
Computing Traditional Applications Many-to-Few Workgroup servers Limited Internet access Many-to-One Mainframes Few workgroup servers Many-to-Many World Wide Web IP the de facto protocol Internet and Intranet Multimedia
needs have resulted in the deployment of... more powerful desktop systems 10 Mbps LANs 10 Mbps LANs Router 100 Mbps FDDI 10 Mbps LANs Router 10 Mbps LANs …and, these applications, desktop systems and servers increasingly “speak” TCP/IP Previously, LAN and backbone bandwidth were well balanced and optimized for text-based applications
LANs LAN Switch Fast Ethernet Hub Router 100 Mbps FDDI Internet Backbone bandwidth bottleneck Router 100 Mbps LANs Fast Ethernet Hub Fast Ethernet Hub LAN Switch Inefficient IP multicast support No QoS support across network
Penetration of TCP/IP 70% Desktop PCs 60% PC Servers Midrange Systems 50% Large Scale Systems 40% 30% 20% 10% 0% 1994 1995 1996 1997 Year 1998 Source: IDC 1999
technologies Limited capacity to handle flow-oriented traffic Poor multicast performance Long lead-time between major performance enhancements ATM with LAN Emulation (LANE) or Classical IP Bridging and single-subnet techniques cannot scale “One-armed” routers easily overwhelmed Multi-protocol over ATM (MPOA) Proposals extremely complex and difficult to manage Proprietary implementations prevent interoperability Architecture Announcements Marketecture futures vs. solution now Better solution still required...
Service IP Router ATM Switch IP Switch IP Software ATM Forum Software IP Software Processor ATM HW ATM HW IP Switching combines the proven functionality of IP with the hardware switching speed of ATM
hop-by-hop using a default virtual channel (VC). ATM cells are reassembled into IP packets at each hop. The IP Switch Controller makes a flow classification decision. IP Switch IP Switch Controller Upstream Node ❶ ATM Cells VPI/VCI = 0/15 ATM Fabric Downstream Node ATM Cells VPI/VCI = 0/15
Controller sends an IFMP message to the upstream node ❷ to use a new VC for the selected flow. ❸ Traffic for the selected flow begins to flow on the new VC — the upstream flow is labeled. ❷ Upstream Node ❸ ATM Cells VPI/VCI = 0/X IP Switch IP Switch Controller ATM Fabric Downstream Node
node also sends an IFMP request for a new VC. Switch sends traffic for that flow to the downstream node on the new VC — ❺ IP the downstream flow is labeled. IP Switch IP Switch Controller Upstream Node ATM Cells VPI/VCI = 0/X ATM Fabric ❹ Downstream Node ❺ ATM Cells VPI/VCI = 0/Y
General Switch Management Protocol Downstream Node ATM Fabric Ipsilon Flow Management Protocol Ipsilon Flow Management Protocol IFMP RFC1953 Protocol specifications available as RFC1953, RFC1954, and RFC1987. Reference implementations available. GSMP Simple protocol that provides call setup, tear-down, and call status Less than 2,000 lines of code Capable of operating with any ATM switch IFMP Protocol between multiple IP Switches or hosts Protocol used to send flow redirection messages
Switching 350,000 350,000 350000 300,000 IP Routing IP RoutingProtocols Protocols Ipsilon 250,000 Software Lines 200,000 of Code IP MPOA 150,000 PNNI IP Routing Protocols IP Routing Protocols Ipsilon 250000 MPOA Q2931 SSCOP IP Routing Protocols Ipsilon 250,000 IP 200000 MPOA 150000 PNNI 100,000 50,000 IP 300,000 300000 IP 200,000 PNNI 100000 Q2931 50000 SSCOP 0 IP Router MPOA MPOA 150,000 PNNI 100,000 50,000 Q2931 IP Routing Protocols IP Routing Protocols IP IP SSCOP Q2931 IP 0 IP Router 0 MPOA IP Router IP Switch Ipsilon
share, for example, the same source/destination addresses, type of service, protocol Long-lived flows are ideal for cut-through switching Short-lived transactions are ideal for datagram forwarding Flow-Oriented Traffic Short-Lived Traffic File transfer (FTP) File sharing (NFS) Web service (HTTP) Web image downloads Multimedia audio/video Name look-up (DNS) Network Time Protocol Email (SMTP) POP SNMP
IP Switch IP Switch Controller ATM Fabric Ipsilon Voyager IP Switch Installation & Monitoring IP Switch Controller IP Switch Controller IP Switch ATM1600 Ip silo n ATM 1600 IP Switching Driver Native Connection Web management Ipsilon IP Switch Gateway IP Switch Gateway IP Switch Controller Optimized direct attachment for servers and hosts High-performance attachment for existing LANs and WANs
IP Switch IP Switch Controller ATM Fabric IP Switch Controller IP Switch Controller IP Switch ATM1600 Ip silo n ATM 1600 Flow Access Fast Ethernet LAN Switch Fast Ethernet Hub IP Switch FAS1200 Fast Ethernet Server Fastest, densest, lowest cost Fast Ethernet backbone
2.5 Gbps non-blocking total bandwidth 1,000,000+ packets per second Port density Up to 24 Fast Ethernet ports Up to 15 ATM OC3 ports (SONET) Physical attributes IP Switch ATM1600 Ip silo n ATM 1600 19-inch rack mountable 261/4 inches (15 UI) high 110/220 VAC (dual power optional) Routing support for IP Switch FAS1200 Unicast and multicast RIP, OSPF, IGRP, DVMRP, IGMP Built-in Quality of Service (QoS) Network management Web via Ipsilon Network Voyager SNMP Telnet
Switch Controller IP Switch ATM1600 Ip silo n ATM 1600 IP Switch FAS1200 IP Switch Installation & Monitoring Web configuration and monitoring Complements Telnet and SNMP Integrated with full documentation Linked to Ipsilon technical support
backbone” Connecting Fast Ethernet LAN switches and hubs Replacing processor-based routers Component of Ipsilon IP Switch Along with Switch Controller and ATM1600
shared bus Compare with hub-to-switch transition Industry-Leading Density Up to 24 Fast Ethernet subnets Ideal backbone for switched networks Accelerated Multicast Full performance multicast using ATM point-to-multipoint Performance scales to match number of recipients Flexible Quality of Service Flow sent on connection with appropriate QoS level Native RSVP coming soon
Processor ATM Fabric Web Management IP Switch Installation & Monitoring IP Switch Controller IP Switch Controller IP Switch ATM1600 Ip silo n ATM 1600 PCI Interfaces IP Switch FAS1200 10-to-1 price/performance advantage over conventional alternatives
learning Corporate broadcasts Market data feeds Desktop conferencing MBONE Software replication is inefficient and slow BUS ATM Forum IP IP Switching IP Switch FAS1200 ATM Cloud BUS server is a single point of failure and can easily be overwhelmed Switch FAS1200 IP Switch FAS1200 Packets are replicated in ATM hardware increasing speed and efficiency
Forum Q.2931 (ISDN-style) RSVP Flow Classification Modify operating system Modify operating system Current operating system Modify applications Modify applications Current applications Install ATM to the desktop Deploy new software Leverages IP Switching
Floor IP Switch Controller Market Data and Transactions ATM Fabric IP Switch Other Data IP Switch Controller IP Switch IP Switch Controller ATM Fabric University Campus Existing Data PointCast IP Phone Web Video ATM Fabric Internet Service Provider First Class Business Class Economy Class Stand-by Class
5 pm Weekends Physical Interfaces Ip silo n IP Switch ATM1600 From IP Addr AT M 1 60 0 IP To IP Addr Source / Dest Addr. IP Switch IP Switch Controller QoS Actions Switching Action Switch cut-through Processor path P1 P2 P3 P4 QoS hardware priority queues ATM Fabric
ISP or Carrier Infrastructure Customer Premises FAS1200 Switch Internet FAS1200 Customer Web Servers Fast Ethernet Rate Shaping Different rates for different price points
Weekends Physical Interfaces IP Switch FAS1200 From IP Addr IP To IP Addr Source / Dest Addr. 10Mbp s Rate Shaping Switching Action Switch cut-through Processor path Rate Shaping Hardware
IP Support Tools > ping > netstat PING frog.ipsilon.com (205.226.9.88): 56 data bytes 64 bytes from 205.226.9.88: icmp_seq=0 ttl=26 time=2.539 ms 64 bytes from 205.226.9.88: icmp_seq=1 ttl=26 time=2.261 ms 64 bytes from 205.226.9.88: icmp_seq=2 ttl=26 time=2.361 ms 64 bytes from 205.226.9.88: icmp_seq=3 ttl=26 time=2.267 ms 64 bytes from 205.226.9.88: icmp_seq=4 ttl=26 time=2.295 ms 64 bytes from 205.226.9.88: icmp_seq=5 ttl=26 time=2.256 ms 64 bytes from 205.226.9.88: icmp_seq=6 ttl=26 time=2.268 ms 64 bytes from 205.226.9.88: icmp_seq=7 ttl=26 time=2.454 ms 64 bytes from 205.226.9.88: icmp_seq=8 ttl=26 time=2.313 ms > traceroute traceroute to frog.ipsilon.com (205.226.9.88), 30 hops max, 40 byte packets 1 spf-1low.Ipsilon.COM (205.226.1.1) 0.727 ms 0.599 ms 0.524 ms 2 foo-6-100.Ipsilon.COM (205.226.6.102) 0.730 ms 0.712 ms 0.707 ms 3 foo-12-110.Ipsilon.COM (205.226.12.116) 0.927 ms 0.951 ms 0.868 ms 4 205.226.10.35 (205.226.10.35) 1.270 ms 1.158 ms 1.117 ms 5 205.226.10.17 (205.226.10.17) 1.715 ms 1.437 ms 1.361 ms 6 205.226.10.52 (205.226.10.52) 1.704 ms 1.566 ms 1.651 ms 7 frog.Ipsilon.COM (205.226.9.88) 2.176 ms 1.903 ms 1.818 ms traceroute to frog.ipsilon.com (205.226.9.88), 30 hops max, 40 byte packets 1 spf-1low.Ipsilon.COM (205.226.1.1) 0.727 ms 0.599 ms 0.524 ms 2 foo-6-100.Ipsilon.COM (205.226.6.102) 0.730 ms 0.712 ms 0.707 ms 3 foo-12-110.Ipsilon.COM (205.226.12.116) 0.927 ms 0.951 ms 0.868 ms 4 205.226.10.35 (205.226.10.35) 1.270 ms 1.158 ms 1.117 ms 5 205.226.10.17 (205.226.10.17) 1.715 ms 1.437 ms 1.361 ms 6 205.226.10.52 (205.226.10.52) 1.704 ms 1.566 ms 1.651 ms 7 frog.Ipsilon.COM (205.226.9.88) 2.176 ms 1.903 ms 1.818 ms Familiar commands Familiar addressing Familiar network segmentation Familiar packet formats SNMP-based Network Manager
Direct-Attached Servers Router 100BaseT OC3 LAN Interfaces 100BaseT IP IP Switch FAS1200 100BaseT 100BaseT 100BaseT FAS1200 Very high IP throughput for bandwidth-intensive applications Supports high-performance IP multicast Supports multiple QoS levels Switch OC3 Backbone IP Switching OC3 Complements existing routed networks and LAN switches Re-establishes the bandwidth balance between the desktop and the backbone 100BaseT LAN Switch LAN Switch LAN Switch IP Switch Gateway LAN Interfaces LAN Interfaces LAN Interfaces FDDI
Ethernet or Fast Ethernet LAN switches with redundant Fast Ethernet uplinks to backbone Redundant IP Switch FAS1200s interconnected by n*OC3 links LAN Switch IP Fast Ethernet LAN Switch IP n*OC3 Switch Switch FAS1200 FAS1200 Fast Ethernet LAN switches with redundant Fast Ethernet uplinks to backbone LAN Switch LAN Switch LAN Switch LAN Switch Hosts connected to LAN switches via Ethernet Subnet 1 Subnet 2 Subnet 3 Subnet 4
100BaseT IP Data link layer: Ethernet, Fast Ethernet and FDDI ATM connectivity: RFC1483 and RFC1954 Router Network layer: RIP, OSPF, IGRP, DVMRP and IGMP Switch FAS1200 100BaseT Uplinks 100BaseT Uplinks LAN Switch LAN Switch LAN Switch LAN Switch LAN Interfaces LAN Interfaces LAN Interfaces LAN Interfaces Network management: Web, SNMP and Telnet
and new IP application servers n*OC3 IP Fast Ethernet IP Switch FAS1200 Hosts connected to LAN switches which are dualLAN Switch LAN Switch homed with Fast Ethernet uplinks to IP Switch FAS1200s and existing routers Fast Ethernet Existing backbone and servers Bldg. 2 Switch FAS1200 LAN Switch Router LAN Switch LAN Switch Fast Ethernet LAN Switch Fast Ethernet FDDI Router LAN Switch LAN Switch IP Switching backbone: High performance QoS support Wire-speed multicast LAN Switch LAN Switch
virtual path service from carriers to connect multiple sites Chicago Extends IP Switching across the wide area IP Switch IP Switch Controller Ipsilon uses virtual channels within the carrier-provided virtual path ATM Switch Multiple virtual paths per port used to connect to multiple WAN sites Permanent Virtual Path ATM Wide Area Service Permanent Virtual Path Los Angeles IP Switch IP Switch Controller ATM Switch Permanent Virtual Path IP Switch IP Switch Controller ATM Switch New York
ATM/Fast Ethernet Backbone 22 Fast Ethernet Ports 14 Fast Ethernet Ports, 4 ATM Ports $213,900 Router IP Switch Controller IP Switch ATM1600 $115,750 Ip silo n IP Switch Controller IP Switch ATM1600 ATM 1600 IP Switch FAS1200 $249,900 Router $92,550 Ip silo n ATM 1600 IP Switch FAS1200
Mbps LANs Internet LAN Switch IP Switching Network Fast Ethernet Hub Internet 100 Mbps FDDI Fast Ethernet Hub IP Switch FAS1200 100 Mbps LANs Fast Ethernet Hub LAN Switch 100 Mbps LANs Router Router Fast Ethernet Hub LAN Switch LAN Switch Gateway Fast Ethernet Hub 100 Mbps LANs Fast Ethernet Hub LAN Switch IP Switching eliminates bandwidth bottlenecks and provides efficient IP multicast and QoS support
Testing Services August 26-30, 1996 Research Triangle Park, NC Interoperability testing of vendors' IP switching implementations GSMP RFC1987 IFMP RFC1953, RFC1954
Internet and WAN IP Switching in workgroups Workgroups Data Center Bell South Carolina Power Duke Univ. IP IFMP Driver MCNC Raleigh, NC IP IFMP Driver Private WAN ATM Network IP Switch attached servers CO ADSL modem IP Switching in the Campus Home ADSL modem IP IFMP Driver IP Switching Broadband Home Access Tools & Appl RADCOM StarBurst Network General
Internet Protocol Combine Ipsilon Software + Video Ipsilon Software IP Switch IP Switch IP Switch IP Switch IP Switch Controller IP Switch Controller IP Switch Controller IP Switch Controller ATM Switch Frame Relay Switch Gigabit Ethernet or FDDI Switch Optical Switch
and switching Flexibility and simplicity of IP routing High performance and quality-of-service of ATM switching Ideal backbone for Fast Ethernet switched network IP Switching is working in real networks right now