Upgrade to Pro
— share decks privately, control downloads, hide ads and more …
Speaker Deck
Sign up for free
Menu
Search
Features
All features
Private URLs
Password Protection
Custom URLS
Scheduled publishing
Remove Branding
Restrict embedding
Deck Collections
Notes
Features
All features
Private URLs
Password Protection
Custom URLS
Scheduled publishing
Remove Branding
Restrict embedding
Deck Collections
Notes
Explore
Featured decks
Featured speakers
Programming
Technology
Storyboards
Explore
Featured decks
Featured speakers
Programming
Technology
Storyboards
Pricing
Search
Sign in
Sign up for free
JANOG39.5_PCE.pdf
Search
Takuya Miyasaka
May 31, 2022
Technology
79
0
Share
Embed
Copy iframe code
Copy JS code
Copy link
Start on current slide
JANOG39.5_PCE.pdf
Takuya Miyasaka
May 31, 2022
More Decks by Takuya Miyasaka
See All by Takuya Miyasaka
JANOG44.5_TRex.pdf
takuyamiyasaka
0
34
BGP Flowspec Indirection-ID Redirect
takuyamiyasaka
0
18
Other Decks in Technology
See All in Technology
無理せず続ける、子育てエンジニアの学び
codmoninc
PRO
0
860
Rust で関数型ドメインモデリング
takonda
0
140
Post AI時代のリファクタリング実践記 / Refactoring in the post AI era
kaminashi
1
230
AI導入は済んだ。次は統制を作り替える番だ_AI×開発組織 Summit 2026
techtekt
PRO
0
210
夫婦で子育てするための育児標準化
codmoninc
PRO
0
330
Railsで挑む大量データ永続化 〜600億件を永続化するための設計とボトルネックとの戦い〜
occhi
1
580
フロントエンドカンファレンス関西2026 - 速すぎるUIに、待ち時間を
teamlab
PRO
0
130
Metadata - Section 1: HTML Basics
mohab1
0
120
脆弱性診断って、何をしているの? 〜弱点を見つけて、会社の改善につなげるまで〜
keeg
0
920
Optunaの最新リリースv5.0について
pfn
PRO
0
120
re:Invent初参加で変わったこと、2回目にやってみたいこと(JAWS-UG彩の国埼玉 #12)
mhrtech
2
220
二歩目のフロントエンド・ウェブアクセシビリティ
camiha
2
570
Featured
See All Featured
Facilitating Awesome Meetings
lara
57
7.2k
Have SEOs Ruined the Internet? - User Awareness of SEO in 2025
akashhashmi
0
520
Statistics for Hackers
jakevdp
799
230k
Getting science done with accelerated Python computing platforms
jacobtomlinson
2
540
The Organizational Zoo: Understanding Human Behavior Agility Through Metaphoric Constructive Conversations (based on the works of Arthur Shelley, Ph.D)
kimpetersen
PRO
0
500
Practical Tips for Bootstrapping Information Extraction Pipelines
honnibal
25
2.1k
エンジニアに許された特別な時間の終わり
watany
109
250k
Gemini Prompt Engineering: Practical Techniques for Tangible AI Outcomes
mfonobong
2
590
Impact Scores and Hybrid Strategies: The future of link building
tamaranovitovic
0
460
GraphQLの誤解/rethinking-graphql
sonatard
75
12k
We Analyzed 250 Million AI Search Results: Here's What I Found
joshbly
2
2k
Site-Speed That Sticks
csswizardry
13
1.6k
Transcript
PCE 〜MPLSネットワークのSDN化を 本気で実現する"唯⼀の"⽅法〜 KDDI 株式会社 宮坂 拓也 1
⾃⼰紹介 • 宮坂 拓也(みやさか たくや) • KDDI株式会社 (AS2516) – ネットワーク技術本部
IPネットワーク部 • KDDIのMPLSバックボーンネットワーク を⽇々いじっています 2
本発表の狙い • PCEというものが世の中に存在するという ことを知って欲しい! • PCEがどのように動作するのか知って欲し い! • PCEを使うとどんなことができるのか知っ て欲しい!
3
Agenda • PCEの概要・なぜ必要なのか? • PCE/PCEP基本動作 • PCEの利⽤事例 4
Agenda • PCEの概要・なぜ必要なのか? • PCE/PCEP基本動作 • PCEの利⽤事例 5
Path Computation Element(PCE) Path Computation Element MPLS経路を 計算する 要素・ノード 1
6 2 3 4 5 PCE Customer A社 Customer A社 (1) A社の新規開 通のため1から6 までのLSP(※1) が必要! (2) 計算した結果、 1,2,4,6というLSPが 一番最適です! ※1 LSP=Label Switched Path 6 (3) 計算結果をルー ターがRSVPなどで シグナリングする
そもそも…, PCEが無い場合… • PCEがネットワークに無い場合はルーター ⾃⾝がパス計算(CSPF)を実施する • それで⾜りない場合は、運⽤者がExplicit にパスを指定する(コンフィグ変更) 1 6
2 3 4 5 Customer A社 Customer A社 ルーター1自身が パス計算を行う 運用者がコンフィ グを変更する (参考) JANOG33 MPLSトラフィックエンジニアリングチュートリアル https://www.janog.gr.jp/meeting/janog33/doc/janog33-mpls-tsuchiya-1.pdf 7
じゃあ、なぜPCEが必要なのか? • ルーターが計算不能な複雑なパス計算を • オペレーターの⼿を借りずに、⾃動に実 施するため ここらへんがタイトルに ”SDN”を⽤いた理由 8 1
6 2 3 4 5 PCE Customer A社 Customer A社 (1) A社の新規開 通のため1から6 までのLSP(※1) が必要! (2) 計算した結果、 1,2,4,6というLSPが 一番最適です! ※1 LSP=Label Switched Path (3) 計算結果をルー ターがRSVPなどで シグナリングする
複雑なパス計算 • ルーターが計算不能な複雑なパス計算は いろいろと存在する – Inter-domain LSP • 異なるドメインをまたがるようなLSP •
異なるドメインのIGP情報を知ることができな いのでルーターでは計算困難 – 複雑なTraffic Engineering • 遅延が何msec以下でジッターが… • ネットワーク全体でトラヒック分布を平準化 したい… (ルーター単体では全体最適は困難) 9
StatelessとStateful • PCEは現在2種類存在する – Stateless PCE (RFC 5440) • PCEはネットワーク内のLSP情報を管理しない
• PCEはパス計算のリクエストを受けたら答えるだけ – Stateful PCE (ietf-pce-stateful-pce) • PCEはネットワーク内のLSP情報を管理する • PCEから以下のようなパス確⽴要求も⾏える – 新規LSPの確⽴ – 既存LSPのパス変更 • Stateful PCEはIETFにおけるSDNコントロー ラー的な位置付けとなっており、近年盛んに 様々な標準化が進んでいる状況です。 10
Agenda • PCEの概要・なぜ必要なのか? • PCE/PCEP基本動作 • PCEの利⽤事例 11
⽤語の説明 • PCE : Path Computation Element – 実際にパス計算を実施するノード •
PCC : Path Computation Client – パス計算のリクエストを投げるノード、実際にLSPを確⽴するノード • PCEP : Path Computation Element Protocol – PCE〜PCC/PCE〜PCE/PCC〜PCC間でパス計算リクエストを送るプロトコル – TCP (port 4189)上で動作 PCC 6 2 3 4 5 PCE Customer A社 Customer A社 PCEP RFC 4665 RFC 5440 12
動作概要(1/2) PCE PCC SYN SYN, ACK ACK OPEN message Keepalive
message … 【OPEN message】 TCPセッション確⽴後に それぞれが送信。 Keepalive/Deadtimer の調整やCapabilityの広 報を⾏う。 【Keepalive message】 PCEPセッションの死活監 視のために定期的にやり 取りされる。 RFC 5440 13
動作概要(2/2) PCE PCC PCReq message 【PCReq message】 パス計算を要求するため のメッセージ。帯域幅な どのパスの要求値と、
Source/Destination IP を⼊れて要求する。 【PCRep message】 PCEが計算したパス情報 をPCCに送信する。 PCRep message Close message 【Close message】 PCEPセッションをclose したいときに送信する。 RFC 5440 14
Stateful PCEで追加された動作 PCE PCC PCRpt message 【PCRpt message】 PCCから現在のLSPの情 報をPCEに送信する。
【PCUpd message】 PCEからPCCに対して既 存LSPの更新メッセージ を送信する。 PCUpd message PCInitiate message 【PCInitiate message】 PCEからPCCに対して、 新規LSPを確⽴する要求 を送信する。 draft-ietf-pce-pce-initiated-lsp draft-ietf-pce-stateful-pce 15
Agenda • PCEの概要・なぜ必要なのか? • PCE/PCEP基本動作 • PCEの利⽤事例 16
Inter-domain LSP 1 2 3 4 5 6 7 8
9 10 Domain 1 Domain 2 PCE (Domain2) PCE (Domain1) 1 2 3 4 5 Domain 1 6 7 8 9 10 Domain 2 1. 10までのLSP が欲しい! 2. 10までのLSP が欲しい! PathKey=Key1 4. {7,Key1}でい けるよ! 6. {1,3,5,7,Key1} でいけるよ! 3. ⾃ドメイン内で計算す る、計算したLSPにPath KeyというIDを振る 5. ⾃ドメイン内 で計算する RFC 5441 RFC 5520 RFC 5553 17
WAN-SDN 1 2 3 4 5 6 7 8 9
10 PCE 1. 7〜9の区間がトラヒックが溢れそう! 2. 7〜9の区間にのっているLSPをピックアップ 3. その中でトラヒックの⼤きいLSPを他のパスに移 す対象に決定 4. 移⾏対象のLSPに対して再度パス計算を実施 5. PCCに対してLSPの変更依頼メッセージを投げる (PCUpdate message) このLSPは {1,2,4,6,8,10} に移ってください 18 Traffic Monitor 7〜9溢れそう! Server
WAN-SDN 1 2 3 4 5 6 7 8 9
10 PCE 1. 7〜9の区間がトラヒックが溢れそう! 2. 7〜9の区間にのっているLSPをピックアップ 3. その中でトラヒックの⼤きいLSPを他のパスに移 す対象に決定 4. 移⾏対象のLSPに対して再度パス計算を実施 5. PCCに対してLSPの変更依頼メッセージを投げる (PCUpd message) このLSPは {1,2,4,6,8,10} に移ってください 19 Traffic Monitor 7〜9溢れそう! PCEはルーターの外にあるので上のようなシナリオ をプログラムにして⾃動化することが容易! Server
SR-TE and PCE 1 2 3 4 5 6 7
8 9 10 PCE {1,4,45,8,10}の SR-TEを作ってくだ さい 20 SR domain Adj-SID=45 • PCEはSR-TEも扱えます – SR-TE = Segment Routing + Traffic Engineering – 今のところ扱えるSID • Node-SID • Adj-SID • Binding-SID • スコープはMPLS-SR (IPv6-SRはスコープ外) draft-ietf-pce-segment-routing draft-sivabalan-pce-binding-label-sid
まとめ • PCE = Path Computation Element –MPLSのパス計算をやってくれます! • PCEはMPLSネットワークのSDNコン
トローラーとして使えます –PCEはSDNにおけるSouthbound Interfaceの1つです! 21