Upgrade to Pro
— share decks privately, control downloads, hide ads and more …
Speaker Deck
Sign up for free
Menu
Search
Features
All features
Private URLs
Password Protection
Custom URLS
Scheduled publishing
Remove Branding
Restrict embedding
Deck Collections
Notes
Features
All features
Private URLs
Password Protection
Custom URLS
Scheduled publishing
Remove Branding
Restrict embedding
Deck Collections
Notes
Explore
Featured decks
Featured speakers
Programming
Technology
Storyboards
Explore
Featured decks
Featured speakers
Programming
Technology
Storyboards
Pricing
Search
Sign in
Sign up for free
ネットワークエンジニアの安息地~ジョークRFCの紹介~
Search
Sponsored
·
Your Podcast. Everywhere. Effortlessly.
Share. Educate. Inspire. Entertain. You do you. We'll handle the rest.
→
モブエンジニア(Masaki Okuda)
March 15, 2025
Technology
300
0
Share
Embed
Copy iframe code
Copy JS code
Copy link
Start on current slide
ネットワークエンジニアの安息地~ジョークRFCの紹介~
2025.03.15 社内登壇資料です
モブエンジニア(Masaki Okuda)
March 15, 2025
More Decks by モブエンジニア(Masaki Okuda)
See All by モブエンジニア(Masaki Okuda)
How to Reduce Network and Container Costs in Container Operations
masakiokuda
1
16
Claude Codeと歩むアプリ開発/App Development with Claude Code
masakiokuda
1
68
ConfigMapのImmutable機能を使ってヒヤッとした話と得られた知見/A Close Call with ConfigMap Immutability and the Lessons Learned
masakiokuda
1
88
Get Started with AI Agent Operations Using Azure SRE Agent
masakiokuda
1
59
あなたの知らないAmazon VPC Route Server/Amazon VPC Route Server you don't know about
masakiokuda
2
300
Oracle Cloud Network Path Analyzerを試してみた/I Tried Out Oracle Cloud Network Path Analyzer
masakiokuda
1
160
20260908_ターゲットとスコープを決める発表法
masakiokuda
1
140
物理もいいけど仮想もね 〜SD-WANの推しポイント〜
masakiokuda
0
190
AIでアウトプットできる時代だからこそ、自分の言葉で考えることの大切さ / What's Left to Think, When AI Can Write?
masakiokuda
1
360
Other Decks in Technology
See All in Technology
分析の民主化を支えるメタデータ整備の実践
kakehashi
PRO
4
1.4k
子育てエンジニアの可処分時間が減っても成長を諦めない戦い方
sudoakiy
6
4.6k
USB PDを使ってスマホを労わりたい
raspython3
0
170
TinyGoでオブザーバビリティ?OpenTelemetryはTinyGoで使えるのか / Is OpenTelemetry available in TinyGo environment?
ymotongpoo
2
140
Kiro Crewをはじめよう
kizawa2020
1
150
Snapshot Testing in Practice: Predictable and Reliable SwiftUI Views
fespinoza
0
220
初海外で注意すべきこと12選!!!安全快適なre:invent生活にするために
yuuuuuuu168
1
120
UniFi(ユニファイ)AIカメラの現場活用
ludicmind
1
430
サブエージェントと Claude Mods で作る独自 Advisor ツールの話
kenichiodo
2
150
ソフトウェア ファクトリー - 再現性のあるソフトウェアの工場づくり / Software factory
iktakahiro
5
4.6k
実践! SRE × AI - ABEMA における AIOps -
tetsuya28
8
3.1k
不可逆な意思決定を避けながら10億超の顧客データを AI Ready にするデータ基盤設計
baseballyama
1
330
Featured
See All Featured
How to build a perfect <img>
jonoalderson
1
6.1k
Agile that works and the tools we love
rasmusluckow
331
22k
Noah Learner - AI + Me: how we built a GSC Bulk Export data pipeline
techseoconnect
PRO
0
460
Building Experiences: Design Systems, User Experience, and Full Site Editing
marktimemedia
1
630
Marketing Yourself as an Engineer | Alaka | Gurzu
gurzu
0
330
Prompt Engineering for Job Search
mfonobong
0
510
The SEO identity crisis: Don't let AI make you average
varn
0
590
Mind Mapping
helmedeiros
1
400
DevOps and Value Stream Thinking: Enabling flow, efficiency and business value
helenjbeal
2
410
Faster Mobile Websites
deanohume
310
32k
How to audit for AI Accessibility on your Front & Back End
davetheseo
0
600
Fight the Zombie Pattern Library - RWD Summit 2016
marcelosomers
234
18k
Transcript
ネットワークエンジニアの安息地 ~ジョークRFCの紹介~ 2925.03.15(土)Advanced Infra Expert Unit 奥田 雅基(オクダ マサキ) 第2回
SKYWILL Beer Bash (ビアバッシュ)
本LTのねらい、対象者 • LTのねらい • ジョークRFCを通じてネットワークを”身近”に感じてもらう • ネットワークに対する”むずかしさ”を払しょくしてもらう • 通信で用いられている技術に興味を持ってもらう •
対象者 • RFCについてよく知らない方 • ネットワークに対して苦手意識を持っている方 • その他(ネットワークつよつよ民になりたい方) 第2回 SKYWILL Beer Bash (ビアバッシュ) 2
お話しすること、お話ししないこと • お話しすること • RFCに関する概要説明 • 私の推しのジョークRFC紹介 • ジョークRFCから見えるネットワークのあり方 •
お話ししないこと • 各RFCに関する詳細説明 • RFCリリースまでの流れ • その他、ネットワークに関する話(プロトコル、ルーティングなど) 第2回 SKYWILL Beer Bash (ビアバッシュ) 3
自己紹介 • 名前 • 奥田 雅基(オクダ マサキ) • 所属 •
Advanced Infra Expert Unit • 担当業務 • SkyAuto開発担当 • 経験 • 2016年に第2新卒で某グループシステム子会社にシステム運 用として入社 • 2019年にスカイウイルへ入社。PMO、ネットワークエンジニア、 教育担当といった経験を積んでまいりました • 好きなレイヤ • L0(データセンター構築、通信基盤など) 第2回 SKYWILL Beer Bash (ビアバッシュ) 4
実は身近にあるRFC https://jprs.jp/tech/material/rfc/RFC1122-ja.txt 第2回 SKYWILL Beer Bash (ビアバッシュ) 5
実は身近にあるRFC https://www.mm-labo.com/computer/tcpip/basic/OSI.html 第2回 SKYWILL Beer Bash (ビアバッシュ) 6
そもそもRFCとは? • RFC(Request for Comments)とは、「コメントを求める」とい う意味で、インターネット技術の標準的な仕様を記した文書であり、 技術情報や運用規則などが定められています。RFCの文書は英語 で作成されており、インターネット上で誰でも閲覧することが可能で す。 •
もともとインターネットの開発は学術目的で始まったもので、仕様など は一般公開されていませんでした。しかし、インターネット技術が高 度化したことで、さまざまな技術仕様に関する一定のルールが必要 となりました。それらのインターネット技術仕様を取り決めているのが RFCです。 https://www.ntt-west.co.jp/business/glossary/words- 00220.html 第2回 SKYWILL Beer Bash (ビアバッシュ) 7
分かりやすく言えば… •ネットワーク界隈の 広辞苑!! 第2回 SKYWILL Beer Bash (ビアバッシュ) 8
そんな広辞苑のようなRFCでもユニークさがあります •それがジョークRFC です!! 第2回 SKYWILL Beer Bash (ビアバッシュ) 9
私が選ぶ、推しジョークRFC • 個人的に私が面白いと思うジョークRFCを5つ選んでみまし た RFC527 RFC1149 RFC2550 RFC9401 RFC9405 第2回
SKYWILL Beer Bash (ビアバッシュ) 10
RFC527(鏡の国のアリス) • 推しポイント • 最古のジョークRFCと 言われているところ https://datatracker.ietf.org/doc/html/rfc527 第2回 SKYWILL Beer
Bash (ビアバッシュ) 11
RFC1149(伝書鳩を用いた通信プロトコル) • 推しポイント • 伝書鳩という「皆さんが 理解しやすいもの」で 通信を説明していると ころ https://datatracker.ietf.org/doc/html/rfc1149 第2回
SKYWILL Beer Bash (ビアバッシュ) 12
RFC2550(2000年問題) • 推しポイント • 2000年(ミレニア ム)問題などの時事 テーマをおもしろおかし く取り上げているところ https://datatracker.ietf.org/doc/html/rfc2550 第2回
SKYWILL Beer Bash (ビアバッシュ) 13
RFC9401(ライトノベルで有名な死亡フラグ) • 推しポイント • ライトノベルなどの若い 方でも知っているテーマ で通信の終了を説明 しているところ https://datatracker.ietf.org/doc/html/rfc9401 第2回
SKYWILL Beer Bash (ビアバッシュ) 14
RFC9405(ChatGPTが執筆) • 推しポイント • ChatGPTといった生 成AIがRFC執筆者と して名前を残している ところ https://datatracker.ietf.org/doc/html/rfc9405 第2回
SKYWILL Beer Bash (ビアバッシュ) 15
まとめ • ジョークRFCの存在を知ることで、「ネットワークって堅い イメージがあったけど、緩いところもあるのね」といった気 付きを得られると思います • そのうえで、本LTを通じてジョークRFCに興味を持った 方は、ぜひ、調べてみてください • (ネットワークに興味を持つ人材を増やしたい…)
第2回 SKYWILL Beer Bash (ビアバッシュ) 16
Fin 第2回 SKYWILL Beer Bash (ビアバッシュ) 17